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1. System Requirements and Installation

1.1 Minimum System Requirements

Before downloading JAS Engineering Suite, verify your computer meets the following minimum requirements:

Operating System Windows 10 (64-bit), version 1903 or later Windows 11 (64-bit), latest update

Processor Intel Core i5 (8th Gen) or AMD Ryzen 5 Intel Core i7 (10th Gen+) or AMD Ryzen 7

RAM 8 GB 16 GB or more

Disk Space 2 GB free for installation 5 GB+ (including project files and weather
data)

Screen Resolution 1366 x 768 1920 x 1080 or higher

Display Scaling 100% or 125% 100% for best layout accuracy
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Graphics Any GPU with DirectX 11 support Dedicated GPU for 3D visualization
Internet Required for initial login, cloud sync, and Al Broadband connection

features
.NET Runtime Not required (standalone Python executable) N/A

Important Notes on Requirements:

 The application is built as a self-contained executable. You do not need to install Python, PyQt6, or any other
runtime. Everything is bundled inside the single EXE file.

* If you plan to use the Revit or AutoCAD integration add-ins, you will need Autodesk Revit 2022-2025 or AutoCAD
2022-2025 installed separately.

» The Al Design Assistant and Proactive Al Engineer features require an internet connection and a cloud API key
(Google Gemini free tier recommended, Claude and OpenAl also supported). On first launch, the Al Setup Wizard will
guide you through obtaining a free API key.

* For 8760-hour annual energy simulations on large buildings (100+ zones), 16 GB RAM is strongly recommended.

1.2 Downloading the Application

The JAS Engineering Suite installer is a single portable executable file. There is no traditional MSI or setup wizard -- the
EXE itself is the application.

Step-by-step download:

1. Open your web browser (Chrome, Edge, Firefox, or any modern browser).
2. Navigate to the download URL:
https://jas-engi neeri ng- downl oads. s3. us-west - 1. amazonaws. coni Desi gn_Sui t e. exe

3. Your browser will begin downloading the file Desi gn_Sui t e. exe. The file is approximately 150-250 MB depending
on the version.

4. Wait for the download to complete. Do not interrupt the download.
5. The file will appear in your default Downloads folder, typically:
C: \ User s\ <Your User nane>\ Downl oads\ Desi gn_Sui t e. exe

Alternative download method:
You can also download from the official website:

1. Goto https://jsengineeringsol utions.com
2. Click the "Download" button on the homepage or navigate to the Downloads page.

3. Click "Download Design Suite" to begin the download.

1.3 Windows Defender SmartScreen Warning

Because JAS Engineering Suite is an independently published application, Windows Defender SmartScreen may show a
warning when you first run the EXE. This is a standard Windows behavior for applications that have not yet accumulated a
large number of downloads to build a reputation with Microsoft.
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How to proceed past the SmartScreen warning:

1. Double-click Desi gn_Sui t e. exe to launch it.

2. A blue Windows Defender SmartScreen window will appear, stating: "Windows protected your PC" with the
message "Microsoft Defender SmartScreen prevented an unrecognized app from starting."

3. Click the text link that says "More info" (this is a clickable link, not a button -- it appears below the warning text in
small blue text).

4. Atfter clicking "More info," two buttons will appear at the bottom of the window: "Don't run" and "Run anyway".
5. Click "Run anyway" to launch the application.

6. You will only need to do this once. After the first successful launch, Windows will remember your choice and will not
show the warning again for this file.

If the SmartScreen dialog does not appear but the application does not launch:

* Right-click the Desi gn_Sui t e. exe file.
« Select "Properties” from the context menu.

« At the bottom of the General tab, look for a message: "This file came from another computer and might be blocked to
help protect this computer.”

» Check the "Unblock" checkbox next to this message.
* Click "Apply", then "OK".

» Now double-click the EXE to launch it.

1.4 Installation Directory and File Placement

JAS Engineering Suite is a portable application. There is no formal installation step. You can run it from any location on
your computer.

Recommended placement:

1. Create a folder for the application:
C:\ Program Fi | es\ JAS Engi neering Suite\
or
C:\ JAS\
2. Move or copy Desi gn_Sui t e. exe into this folder.

3. Optionally, right-click the EXE and select "Create shortcut", then drag the shortcut to your Desktop or pin it to the
Taskbar for quick access.

Application data location:
The application stores its settings, user database, and cached data in:

% OCALAPPDATA% MEP- Desi gn- Sui t e\

Which typically resolves to:

C: \ User s\ <Your User nane>\ AppDat a\ Local \ MEP- Desi gn- Sui t e\

This directory contains:
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e settings.json -- Your application preferences (theme, window mode, recent projects, code standard selections)
e users. db -- Local SQLite database for user authentication, license keys, and 2FA secrets
 Cached license validation data

Project files location:
By default, project files (.mep format) are stored in:

%JSERPROFI LE% Docunent s\ JAS Proj ect s\

You can save projects to any location you choose.

1.5 First Launch: What You Will See

When you launch JAS Engineering Suite for the first time, the following sequence occurs:

1. Splash Screen (3-8 seconds): A dark, animated splash screen appears with the JAS Engineering Suite logo, a
progress bar showing loading status, animated loading dots, and the text "Professional MEP Design & Analysis Tools"
below the title. The progress bar fills from 0% to 100% as modules are loaded. Status messages cycle through items
like "Initializing...", "Loading modules...", "Preparing workspace..." etc. The splash screen features a pulsing cyan glow
effect and an animated accent line that sweeps across the top.

2. Login Dialog (fullscreen): After the splash screen finishes, a fullscreen login dialog appears. This is a
glassmorphism-styled dialog with a background image (your selected logo theme), a semi-transparent login panel in
the center, and a theme selector dropdown in the upper right corner. Since this is your first launch, you will need to
register an account. See Section 2 for complete details.

3. Main Application Window: After successful login, the main application window appears with the left sidebar, top
menu bar, central dashboard, and bottom status bar. The window opens maximized by default.

1.6 Updating the Application

To update JAS Engineering Suite to a newer version:
1. Download the latest Desi gn_Sui t e. exe from the same S3 URL listed above (it always points to the latest version).
2. Close any running instance of the application.
3. Replace your existing Desi gn_Sui t e. exe file with the newly downloaded one.

4. Launch the updated EXE. Your settings, projects, and user account are preserved because they are stored
separately in % OCALAPPDATA% MEP- Desi gn- Sui t e\ .

You can check for updates from within the application by going to Help > Check for Code Updates... in the menu bar.

2. Account Registration and Login

JAS Engineering Suite requires a user account to operate. Accounts are stored locally in an SQLite database on your
machine, with optional cloud synchronization for collaboration features.

2.1 The Login Dialog in Detail
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When the application starts, you see the Login Dialog. Here is every element on this screen:
Top Right Corner -- Theme Selector:

* A "Theme:" label and a dropdown combobox appear in the upper right.

 The dropdown lists all 40+ available themes organized by category (Dark themes, Light themes, Lightsaber themes,
Lightning themes, Special Edition themes, Color themes).

* Selecting a different theme instantly changes the entire application appearance, including this login dialog.
 The selected theme is saved to your settings file and persists across sessions.

Center -- Login Panel:

* The login panel is a rounded rectangle with a semi-transparent dark background (rgba(12, 12, 20, 0.8))anda
subtle border glow in the primary theme color.

 The panel is 420 pixels wide minimum and vertically centered on the screen.

Panel Contents (top to bottom):

1."Login" Title -- Large bold text in cyan (#00d4ff), centered at the top of the panel.

2. Email Field:

* Label: "Email:" (light gray text, 13px)

* Input: A text field with placeholder text "Enter email address"

e Minimum height: 44 pixels

 Dark background with a subtle border that turns cyan when focused

« This field accepts the email address you used during registration

3. Password Field:

* Label: "Password:" (light gray text, 13px)

* Input: A text field with placeholder text "Enter password"

» Characters are masked (shown as dots) for security

e Minimum height: 44 pixels

* Pressing Enter in this field triggers the login action

4. "Remember me" Checkbox:

» A small checkbox with gray label text

» When checked, the application saves a session token so you do not need to re-enter credentials on the next launch
» The checkbox state is persisted in the Windows registry under HKCU Sof t war e\ JSEngi neer i ng\ JSEngi neeri ngSuite
5. Error Label (hidden by default):

* When a login attempt fails, a red (#ff6b6b) error message appears here

« Common messages: "Please enter email and password", "Please enter a valid email address", "Invalid email or
password"

6. "Login" Button:
* A large cyan button (minimum height 46px)

e Text: "Login" in bold white

JAS Engineering Suite v1.2 — Sample Project User Guide Page 6



JAS Engineering Suite Guide 00 Getting Started

« Clicking this button or pressing Enter in the password field attempts authentication

« The button changes to a lighter cyan on hover and a darker shade when pressed

7. Register Link:

* Text: "Don't have an account?" followed by a clickable "Register" button in cyan

» Clicking "Register" switches the view to the Registration Dialog

8. 2FA Badge:

« At the bottom of the panel, a small green shield icon with text "Two-Factor Authentication Supported"
« This is informational only and indicates the application supports TOTP-based 2FA

Bottom -- Footer:

* "JAS Engineering Suite v1.2 | (c) JAS Engineering Solutions" in semi-transparent white text

Keyboard Navigation:

» Tab: Move between Email field, Password field, Remember Me checkbox, and Login button
« Enter: If focus is in the Password field, triggers login. If focus is on the Login button, triggers login.

 Escape: Closes the login dialog and exits the application

2.2 Login Process Step by Step
Type your registered email address in the "Email” field.
Type your password in the "Password" field.

Optionally check "Remember me" to skip login on future launches.

1.

2.

3.

4. Click the "Login" button or press Enter.

5. If login succeeds and 2FA is NOT enabled: You proceed directly to the main application.

6. If login succeeds and 2FA IS enabled: A Two-Factor Authentication dialog appears (see Section 2.5).
7.

If login succeeds and 2FA is NOT enabled but you have not set it up: A "Secure Your Account with 2FA" dialog
appears prompting you to set up 2FA. You can set it up, skip for now ("Set Up Later"), or choose "Don't Ask Again."

8. If login fails: A red error message appears below the password field. Check your email and password and try
again.

Behind the scenes during login:

 The application authenticates against the local SQLite database using PBKDF2-SHA256 hashing (100,000
iterations).

 Simultaneously, it attempts to fetch a JWT (JSON Web Token) from the cloud API at
https://api .| sengi neeringsol utions. cont api/auth/ | ogi n for collaboration features. This is non-blocking -- if the
cloud API is unreachable, local login still succeeds.

« If the cloud account has 2FA enabled and the local account does not, the cloud TOTP secret is automatically synced
to the local database so both accounts use the same authenticator code.

2.3 Registration Dialog in Detail
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If you click "Register" from the Login Dialog, or if this is your very first time using the application, you will see the
Registration Dialog.

Window Properties:

» Title: "JAS Engineering Suite - Register"
* Minimum size: 420 x 560 pixels
* Modal dialog (you cannot interact with other windows while it is open)

Form Fields (top to bottom):

1. "Create Account" Title -- Large bold text in the primary theme color, centered.
2. Email Field:

e Label: "Email:"

* Placeholder: "Your email address (used for login)"

* Minimum height: 36 pixels

* This email becomes your unique login identifier. It must contain an "@" symbol and at least one "." in the domain.
» Example: j ohn. snmi t h@cnehvac. com

3. Name Field:

* Label: "Name:"

* Placeholder: "Your full name"

* Minimum height: 36 pixels

* This is your display name. If left blank, the portion of your email before "@" is used.
* Example: John Snith

4. Password Field:

e Label: "Password:"

* Placeholder: "Choose a password (min 6 chars)"

* Minimum height: 36 pixels

» Characters are masked (dots)

* Minimum length: 6 characters (enforced during registration)

5. Confirm Password Field:

e Label: "Confirm:"

* Placeholder: "Confirm your password"

* Minimum height: 36 pixels

* Characters are masked

* Must exactly match the Password field

* Pressing Enter in this field triggers the registration action

6. License Key Group Box:

« Titled "License Key (Required)" with a bordered group box
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* Input field with placeholder: "MEP-XXXX-XXXX-XXXX or TRIAL-2026-EVAL-FREE"

e Minimum height: 36 pixels

* Below the input: "For 30-day trial, enter: TRIAL-2026-EVAL-FREE" in muted gray text

* Below that: "Purchase license: Contact xmanjames@gmail.com" with the email as a clickable mailto link

License Key Formats Accepted:

* Trial key: TRI AL- 2026- EVAL- FREE (provides 14-day evaluation period)

« Standard key: MEP- XXXX- XXXX- XXXX (format: 3-6 character prefix, dash, then three groups of 4 uppercase
alphanumeric characters)

* Any key matching the pattern Xxxx- xxxx- Xxxxx- XxxxX (four groups of 3-6 uppercase alphanumeric characters)
7. Error Label (hidden by default):
» Red text appears here if registration fails

« Common messages: "Please fill in email and password", "Please enter a valid email address", "License key is
required...", "Passwords do not match", "Email already registered"”

8. "Create Account" Button:

» Green (#10b981) button with bold white text

e Minimum height: 40 pixels

« Clicking this triggers the registration process

9. Back to Login Link:

* "Already have an account?" followed by a clickable "Login" link in the primary theme color

« Clicking this returns to the Login Dialog

2.4 Registration Process Step by Step

. Enter your email address in the Email field.

. Enter your full name in the Name field (optional but recommended).

. Choose a password (minimum 6 characters) and type it in the Password field.

. Re-type the same password in the Confirm field.

. Enter a license key in the License Key field. For evaluation, type: TRI AL- 2026- EVAL- FREE

. Click "Create Account".

N o o b~ W N P

. If registration succeeds:
A local account is created in the SQLite database.

 Simultaneously (in a background thread), a cloud account is automatically created at
https://api.jsengineeringsol utions. conf api/auth/register. This is silent and non-blocking -- if it fails, your local
account still works.

 The application attempts to automatically log you in and activate the license key (first trying online activation, then
falling back to local activation).

« If the license activation fails, a warning dialog appears saying "Account created but license activation failed" -- you
can add a license later from Settings > User Account > License Management.
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« If everything succeeds, an "Account created!" success dialog appears.

* You are then automatically logged in and the main application window opens.
8. If registration fails:

« A red error message appears in the error label area.

» Common reasons: email already registered, invalid email format, passwords do not match, license key format
invalid.

2.5 Two-Factor Authentication (2FA)

JAS Engineering Suite supports TOTP (Time-based One-Time Password) two-factor authentication, compatible with
Google Authenticator, Authy, Microsoft Authenticator, and any other TOTP-compatible app.

2.5.1 Setting Up 2FA

After your first login (if 2FA is not yet configured), a "Secure Your Account with 2FA" dialog appears automatically:
Dialog Contents:

1. Title: Shield icon with "Secure Your Account with 2FA" in bold primary color, centered.

2. Description: "Two-Factor Authentication adds an extra layer of security to your account. Even if someone gets
your password, they won't be able to access your account without your phone."

3. QR Code: A 220x220 pixel white-bordered frame containing a QR code. This QR code encodes an
ot paut h: // t ot p/ URI with the application name "JAS Engineering Suite" as the issuer and your username as the
account name.

4. Instructions:

« "1. Install an authenticator app (Google Authenticator, Authy, etc.)"

« "2. Scan this QR code with the app"

« "3. Enter the 6-digit code below"

5. Code Input Field:

* A large centered input field (font-size 24px, letter-spacing 8px) for entering the 6-digit code
* Placeholder: "Enter 6-digit code"

» Maximum length: 6 characters

* Pressing Enter triggers verification

6. "Enable Two-Factor Authentication" Button:

» Green success-colored button

« After successful verification, changes to "2FA Enabled!" and becomes disabled

7. Skip Options:

 "Set Up Later" -- closes the dialog without enabling 2FA; you will be prompted again on your next login

« "Don't Ask Again" -- closes the dialog and saves a preference to never show the 2FA setup prompt again (you can
still enable 2FA later from Settings > User Account > Two-Factor Authentication)

Step-by-step setup process:
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. When the QR code dialog appears, open your authenticator app on your phone.

. In the authenticator app, tap the "+" or "Add Account" button.

. Choose "Scan QR Code" (or "Scan Barcode").

. Point your phone's camera at the QR code displayed in the dialog.

. The authenticator app will create a new entry labeled "JAS Engineering Suite" with your username.
. The app will now display a 6-digit code that changes every 30 seconds.

. Type the current 6-digit code from your authenticator app into the code input field.

. Click "Enable Two-Factor Authentication”.

. If the code is valid, a success message appears and a Backup Codes dialog is shown.

10. Critical: Save your backup codes. The Backup Codes dialog displays 10 recovery codes in the format
XXXX- XXXX. Write these down or save them in a secure location. Each backup code can only be used once. If you lose
access to your authenticator app, these codes are the only way to log in.

11. Click "OK" to close the backup codes dialog. 2FA is now active on your account.

If the QR code fails to generate:

* The dialog will display the TOTP secret as plain text (e.g., JBSW3DPEHPK3PXP).

« In your authenticator app, choose "Enter a setup key" (or "Manual entry") instead of scanning a QR code.

* Type the secret key displayed in the dialog.

» Set the account name to your username and the issuer to "JAS Engineering Suite".

2.5.2 Logging In with 2FA

When 2FA is enabled, the login process adds an extra step:

© 00 N o o b~ W N P

. Enter your email and password as usual and click Login.

. If credentials are correct, a "Two-Factor Authentication" verification dialog appears.

. The dialog title says "Enter Verification Code".

. Instructions: "Enter the 6-digit code from your authenticator app or use a backup code."”
. A large centered input field (font-size 24px) with placeholder "000000".

. Open your authenticator app and find the current 6-digit code for JAS Engineering Suite.
. Type the 6-digit code into the field.

. Click "Verify" or press Enter.

. If the code is valid, you are logged in.

10. If the code is invalid, an error message "Invalid verification code. Please try again.” appears, the field is cleared,
and you can try again.

11. To cancel, click "Cancel" -- this returns you to the login dialog.

Using a backup code instead:

« In the verification code field, you can enter one of your backup codes instead of the TOTP code.

» Backup codes are 8-character alphanumeric strings in the format XXxX- XXXX.
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* Enter the backup code (with or without the dash) and click Verify.
 The backup code is consumed (removed from your list of valid codes) after successful use.

* You can regenerate backup codes from Settings > User Account > Two-Factor Authentication.

2.5.3 Unified 2FA Between Desktop and Cloud

JAS Engineering Suite uses a unified 2FA system. When you log in:

« If the cloud API has 2FA enabled for your account and your local installation does not, the cloud's TOTP secret is
automatically synced to your local database. This means your authenticator app entry works for both the desktop
application and the web portal.

« If the cloud requires a 2FA code during JWT fetch, the code you enter locally is also forwarded to the cloud API.

2.6 Password Requirements
* Minimum length: 6 characters
* No maximum length enforced

* No special character requirements (however, using a mix of uppercase, lowercase, numbers, and symbols is
recommended)

» Passwords are hashed using PBKDF2-HMAC-SHA256 with 100,000 iterations and a random 32-byte salt

* Legacy accounts (from older versions) using SHA-256 hashing are automatically verified with the legacy method

2.7 Password Reset

Currently, password reset is handled locally:

1. If you have forgotten your password and cannot log in, you will need to contact support at
j ames@ sengi neeri ngsol utions. com

2. For the cloud web portal, password reset via email is available at

https://jsengi neeringsol utions.confauth. htm .

3. As a local workaround (not recommended for production), an administrator can reset passwords through the
Settings > User Account > User Management dialog if they have admin role access.

2.8 Offline Mode

JAS Engineering Suite works fully offline after initial login:
What works without internet:

* All calculation modules (load calculations, duct sizing, pipe sizing, equipment selection, etc.)
* All 523+ weather data locations (weather data is bundled in the application)

* Project file save/load (.mep files)

» Report generation (PDF, Excel, TXT)

* Login (credentials are verified against local SQLite database)

* 2FA verification (TOTP is computed locally)
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« All compliance checking (ASHRAE 90.1, Title 24, etc.)
« All code references and standards databases

What requires internet:

* Cloud collaboration (Share Project, Open Shared Project, Team Online)

« Al Design Assistant (requires cloud API key -- Gemini free tier, Claude, or OpenAl)
* Proactive Al Engineer (cloud-based analysis)

« License activation via the online portal

* Cloud account registration

» Checking for application updates

* CEC Registry submission

2.9 User Roles

The application supports three user roles:

Admin Full access to all features, user management, license management,
can create/delete user accounts

User Full access to all engineering tools, project management, and reporting
(default role for new accounts)

Viewer Read-only access to projects and reports; cannot modify calculations
or save projects

New accounts are created with the User role by default.

3. Dashboard Navigation

After successful login, the main application window appears. This section describes every element of the interface in
detail.

3.1 Application Window Layout

The main window is divided into four regions:
| MENU BAR (File | Settings | Tools | View | Help) |

I

| LEFT | CENTRAL AREA |

| SIDEBAR | (Dashboard / Tool Content) |
[ ]|

| (Tool | |

| List) | |

I
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3.2 The Dashboard (Central Area)

When no tool is active, the central area displays the Dashboard. The dashboard has the following sections from top to
bottom:

3.2.1 Header Row
« Left: "JAS Engineering Suite" in large bold primary-colored text (22px font).

* Right: Today's date in the format "Wednesday, February 20, 2026" in secondary gray text.

3.2.2 KPI Stat Cards Row

Four stat cards are displayed in a horizontal row, each with a colored top border accent:

1. Active Project (cyan top border)

» Shows the name of the currently loaded project

* If no project is loaded: "No project loaded"

« If a project is loaded: displays the project name

2. Recent Activity (green top border)

» Shows the number of tools used during the current session
» Example: "3 tools used today"

3. Available Modules (orange top border)

» Shows the total count of available engineering tools
* Typically displays: "150+ tools"

4. System Status (blue top border)

» Shows the application readiness state

* Normal state: "Ready"

* During calculations: "Calculating..."

Each card has a dark card background (#12121a) with a subtle border and rounded corners.

3.2.3 Quick Actions Row

Below the stat cards, a "Quick Actions" section provides one-click access to the most common tasks:

New Project Cyan Creates a new empty project

Open Project Blue Opens the file dialog to load an existing .mep
file

Energy Calcs Orange Launches the Energy Calculations module
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Duct Sizer Cyan Launches the Duct Sizer tool
Pipe Sizer Green Launches the Pipe Sizer tool
Reports Purple Launches the Reports and Diagrams module

Each button is 52 pixels tall with a left-side color accent bar, dark background, and hover effect.

3.2.4 Two-Column Layout: Recent Projects and Recently Used Tools

Below the Quick Actions, the dashboard splits into two columns:
Left Column -- Recent Projects:

» Header: "Recent Projects” in bold secondary text

* A list widget (maximum 200px tall) showing the file paths of your most recently opened projects
» Each entry is clickable -- double-click to open the project

« If no projects have been opened: the list is empty

* Projects are listed in reverse chronological order (most recent first)

» Hover highlights the entry; selected entry highlights in the primary theme color

Right Column -- Recently Used Tools:

» Header: "Recently Used Tools" in bold secondary text
* A flow layout showing chip/tag buttons for tools you have recently launched
 Each chip shows the tool name and is clickable to relaunch

« If no tools have been used in the current session: this area is empty

3.3 Left Sidebar: Tool Categories

The left sidebar is the primary navigation element. It occupies approximately 280 pixels wide and contains a vertically
scrollable list of all engineering tools organized by category.

3.3.1 Sidebar Header
At the top of the sidebar:
*"TOOLS" label in uppercase bold primary-colored text

« "Collapse All" / "Expand All" button -- a small button in the top-right of the header that toggles all categories
between collapsed and expanded states

3.3.2 Search Box

Directly below the header is a search filter:

* A magnifying glass icon ("search") followed by a text input field
* Placeholder text: "Search tools..."

« The field has a clear button (X) on the right side that appears when you type
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* How it works: As you type, the sidebar dynamically filters to show only tool buttons whose names contain your
search text. Category headers for empty categories are hidden. Categories with matching tools are automatically
expanded.

* Example: Typing "duct" will show "Duct Sizer", "Duct Insulation”, and their parent categories, hiding everything else.

* Clearing the search box restores all categories and tools to their original state.

3.3.3 Special Sections

Before the main tool categories, two special sections appear:
FAVORITES (orange accent):

* Click the "FAVORITES" header to expand/collapse
« Contains tools you have marked as favorites
e To add a favorite: right-click any tool button and select "Add to Favorites"

RECENTLY USED (cyan accent):

* Click the "RECENTLY USED" header to expand/collapse
» Automatically populated with tools you have recently launched
* Limited to the most recent 5-8 tools

A thin horizontal separator line divides these special sections from the main categories.

3.3.4 Tool Category List (Complete Reference)
Below the separator, every tool category and its tools are listed. Each category has:
* A colored header bar with a left-side accent line
» An expand/collapse arrow (down-arrow = expanded, right-arrow = collapsed)
« A tool count badge in parentheses showing how many tools the category contains
* Click the category header to toggle expand/collapse

The expand/collapse state is persisted in settings, so your collapsed/expanded preferences are remembered between
sessions.

Here is the complete list of all categories and their tools:

1. HVAC LOAD CALCULATIONS (Orange accent)

Energy Calculations Whole-building heating and cooling load calculations per ASHRAE
methodology

Envelope Editor Define and edit wall, roof, floor, and fenestration assemblies with
U-factor calculations

Building Analysis Analyze building performance metrics including energy use intensity
and peak loads

Reports & Diagrams Professional load calculation reports, system diagrams, and
compliance forms
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Project Report (PDF) Generate comprehensive project report in PDF format

Data Visualizer (8760) Visualize 8,760-hour annual energy simulation data with interactive
charts

Parametric System Sweep Compare HVAC system alternatives side-by-side with automated

parametric analysis

2. SIZING TOOLS (Cyan accent)

Duct Sizer Calculate duct sizes per SMACNA for round, rectangular, and flat oval
ducts
Pipe Sizer Size hydronic and plumbing piping based on flow rate, velocity, and

pressure drop

Pump Calculator Select and size pumps using system curve analysis and manufacturer
performance data

Ventilation (62.1) Calculate outdoor air ventilation rates per ASHRAE Standard 62.1

ESP Calculator Calculate external static pressure for air handling units and fan
selection

Louver Sizing Size intake and exhaust louvers for required free area and weather
protection

Door Undercut Calculate door undercut dimensions for transfer air between pressure
zones

3. PLUMBING TOOLS (Blue accent)

Fixture Calculator Calculate plumbing fixture unit counts and pipe sizing per IPC/UPC
codes
Water Pressure Calc Analyze domestic water pressure from source to highest fixture with

friction losses

Gas Pipe Sizer Size natural gas and propane piping per IFGC using longest-length
method

Hot Water Sizing Size hot water distribution piping and calculate recirculation loop heat
loss

Domestic Hot Water Design domestic hot water systems including heater sizing and storage

tank selection

Waste Pipe Invert Calculate waste pipe invert elevations and slopes for gravity drainage
systems

4. PLANT EQUIPMENT (Green accent)
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Chiller Plant Design chiller plants with equipment selection, piping layout, and
sequence of operation

Boiler Plant Design boiler plants with equipment selection, piping layout, and
sequence of operation

Equipment Schedule Create and manage HVAC equipment schedules with manufacturer
catalog data

Equipment Wizard Step-by-step wizard for selecting and configuring HVAC equipment

5. ADDITIONAL TOOLS (Purple accent)

Psychrometrics Interactive psychrometric chart with air process plotting and state-point
calculations
Unit Converter Convert between IP and Sl units for all common HVAC and plumbing

engineering values

Noise Calculator Calculate sound power levels, transmission loss, and duct attenuation
for HVAC noise

Mixed Air Calculator Determine mixed air temperature and enthalpy from outdoor and return
air streams

Expansion Tank Sizing Size expansion tanks for closed hydronic systems per ASHRAE
guidelines

Refrigerant Pipe Sizing Size refrigerant suction, liquid, and discharge lines with oil return
verification

6. SPECIALTY HVAC (Red accent)

Kitchen Hood Design commercial kitchen exhaust hoods per IMC/NFPA 96 with
makeup air calculations

Parking Garage Vent Calculate parking garage ventilation rates per IMC for CO and NO2
dilution
Lab / Fume Hood Design laboratory HVAC with fume hood exhaust, air change rates,

and pressure cascades

Pool / Natatorium Design natatorium HVAC systems with dehumidification and
corrosion-resistant materials

Stairwell Pressurization Calculate stairwell pressurization fan sizing per IBC for smoke control
compliance

Data Center Cooling Design data center cooling with rack-level analysis and PUE
optimization

7. ELECTRICAL TOOLS (Orange accent)
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Voltage Drop Calculate conductor voltage drop for branch circuits and feeders per
NEC

Conduit Fill Determine conduit fill percentages per NEC Chapter 9

Motor Circuit Size motor branch circuits including overload protection, wire, and

conduit per NEC Atrticle 430

Transformer Sizing Size dry-type and liquid-filled transformers based on connected and
demand loads

Lighting Calculator Calculate lighting power density and illumination levels per IES and
energy codes

Short Circuit Perform short circuit analysis to verify equipment AIC ratings

One-Line Diagram Generate single-line electrical diagrams showing power distribution

8. PLANT / SYSTEM TOOLS (Cyan accent)

Air Balance Create air balance reports with supply, return, exhaust, and outdoor air
flow measurements

Pump Curves Plot and analyze pump performance curves with system curve overlay

Grease Interceptor Size grease interceptors per PDI G101 and local plumbing code
requirements

Heat Exchanger Design and rate shell-and-tube and plate heat exchangers

Cooling Tower Select and rate cooling towers based on approach, range, and
wet-bulb conditions

Control Diagrams Generate HVAC control system diagrams with points lists and
sequences

VAV Box Sizing Size variable air volume terminal units

Diffuser Selection Select supply air diffusers and grilles based on throw, NC, and

pressure drop

Acoustics NC/RC Calculate NC and RC noise criteria ratings for occupied spaces

Glycol Properties Look up thermophysical properties of ethylene and propylene glycol
solutions

Steam Pipe Sizing Size steam supply and condensate return piping

Fan Laws Apply fan laws to predict performance changes from speed, diameter,

and density variations

Duct Insulation Calculate duct insulation thickness for condensation prevention and
energy code compliance

9. SPECIALTY ENGINEERING (Purple accent)
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Fire Protection Design fire protection systems including sprinkler hydraulic
calculations per NFPA 13

Smoke Control Design smoke control systems per IBC Chapter 9

Vibration Analysis Analyze equipment vibration isolation requirements

Cleanroom Design Design cleanroom HVAC with ISO classification, HEPA filtration, and
pressurization

Pipe Network Analyze complex pipe networks with multiple loops using Hardy Cross
iteration

Pool/Natatorium Design pool and natatorium HVAC systems with humidity control

CFD Integration Interface with computational fluid dynamics tools for airflow
visualization

10. COMPLIANCE & SUSTAINABILITY (Green accent)

PHIUS Passive House Verify compliance with PHIUS passive house certification
WELL Building Check project compliance with WELL Building Standard
Title 24-2022 California Title 24-2022 energy code compliance analysis with

NRCC/LMCC forms
ASHRAE 90.1-2022 ASHRAE Standard 90.1-2022 energy code compliance

CEC Registry Submission Prepare and submit Title 24 compliance documents to the California
Energy Commission

Carbon Footprint Calculate embodied and operational carbon emissions

Grid-Interactive (GEB) Design grid-interactive efficient buildings with demand response
11. REFERENCES & STANDARDS (Blue accent)

Code Reference (Al) Al-powered building code lookup across ASHRAE, IBC, IMC, NFPA,
and local amendments

ASHRAE Standards Browse and reference ASHRAE standards (90.1, 62.1, 55, 189.1)

ASHRAE Weather Data Access ASHRAE design weather data for 523+ US and international
locations

NFPA Codes Browse NFPA fire codes (13, 72, 90A, 101)

IPC/CPC Plumbing Reference International and California Plumbing Code requirements

Al Design Assistant Chat with an Al assistant trained on HVAC engineering standards

Proactive Al Engineer Al that proactively generates equipment schedules, sequences, and

design validation

12. INTERNATIONAL CODES (Cyan accent)
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Eurocode (EN Standards) European EN standards compliance for HVAC and energy
performance

British Standards (CIBSE) CIBSE guides and British Standards for UK building services design

Australian Standards (NCC) Australian NCC and AS/NZS standards

Canadian Codes (NBCC/NECB) Canadian NBCC, NECB, and CSA standards

Middle East Codes (Gulf) Gulf region codes including Estidama, DEWA, and Ashghal standards

13. ENGINEERING SERVICES (Blue accent)

Generator/UPS Size emergency generators and UPS systems

Seismic Restraints Calculate seismic bracing and restraint requirements per ASCE 7

TAB Reports Testing, adjusting, and balancing reports per AABC/NEBB/TABB
standards

TAB Contractor Manage TAB contractor workflows

Pressurization Plan Create building pressurization plans

Commissioning Manage building commissioning process

LEED Credits Track and document LEED credit compliance

Life Cycle Cost 25-year life cycle cost analysis comparing HVAC alternatives

Specification Writer Generate HVAC specifications using UFGS and MasterSpec templates

14. FIELD SERVICES (Orange accent)

Field Survey Conduct field surveys with mobile data collection

Equipment Inventory Catalog existing HVAC equipment with nameplate data and condition
ratings

Space Assessment Document space conditions (dimensions, ceiling heights, existing
systems)

TAB Data Collection Collect field TAB measurements

Deficiency Tracking Track and manage field deficiency observations with photos and

corrective actions

15. HVAC SYSTEM DESIGN (Cyan accent)

Central Plant Design central heating and cooling plants with primary/secondary
piping
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VRF Design

DOAS Systems

Heat Recovery

Chilled Beams

Ground Source HP

16. CONTROLS & BAS (Orange accent)

Design variable refrigerant flow systems with indoor/outdoor unit
selection

Design dedicated outdoor air systems with energy recovery and
dehumidification

Design heat recovery systems (run-around loops, enthalpy wheels,
heat pipes)

Design active and passive chilled beam systems

Design ground-source heat pump systems with bore field sizing

Controls Wizard

Control Sequences

BACnet Design
DDC Programming

Sensors & Actuators

17. CONSTRUCTION ADMIN (Red accent)

Step-by-step wizard for designing HVAC control systems

Write and manage HVAC control sequences per ASHRAE Guideline
36

Design BACnet building automation networks
Develop direct digital control programs with logic diagrams

Select and specify sensors, actuators, and control valves

RFI/Submittal

Daily Log

Change Orders
Pay Applications
Meeting Minutes
Transmittals
Permit Tracker
Punch List

Closeout Docs

Cost Tracking
As-Built Manager
OSHA Compliance

Warranty Tracker
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Manage requests for information and submittals with KPI dashboard

Record daily construction activities, weather, workforce, and
equipment

Track change orders with cost and schedule impact analysis
Prepare pay applications with schedule of values and retainage
Record and distribute meeting minutes with action item tracking
Create and track document transmittals

Track building permit status and inspections

Create and manage construction punch lists

Manage project closeout documents (O&M manuals, warranties,
as-builts)

Track project costs against budget
Manage as-built drawing markups
Track OSHA safety compliance requirements

Track equipment and system warranties with expiration alerts
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18. ENTERPRISE TOOLS (Purple accent)

Project Templates Create and manage reusable project templates

Batch Processing Run calculations across multiple zones or projects simultaneously
Workflow Manager Define and manage engineering workflow stages

Report Engine Generate professional PDF reports for load calculations, equipment,

and compliance

Proposal Generator Create engineering service proposals with scope, schedule, and fee
estimates

Collaboration Share projects and collaborate in real-time

Audit Log View detailed audit trail of all project changes

Project Schedule Create and manage project schedules with Gantt charts

19. EMERGING TECHNOLOGIES (Green accent)

Hydrogen Systems Design hydrogen fuel cell and distribution systems
Smart Grid Design smart grid integration with demand response
EV Infrastructure Design electric vehicle charging infrastructure
Microgrids Design building or campus microgrid systems
Thermal Storage Design ice and chilled water thermal energy storage
Carbon Capture Evaluate building-scale carbon capture technologies

20. RENEWABLE ENERGY (Orange accent)

Advanced Solar Photovoltaic and solar thermal systems with production and financial
analysis

Wind Systems Small wind turbine installations with wind resource analysis

Geothermal Systems Geothermal heating and cooling with ground heat exchanger sizing

DER Integration Distributed energy resources (solar, storage, generators)

Waste Heat Recovery Capture and reuse process and exhaust heat

Trigeneration Combined cooling, heating, and power trigeneration systems

21. ADVANCED TECHNOLOGIES (Cyan accent)

Advanced Refrigerants Low-GWP and natural refrigerant options
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District Energy District heating and cooling with central plant and distribution network
Energy Recovery Adv Advanced energy recovery (enthalpy wheels, run-around coils)
Thermal Comfort ASHRAE Standard 55 with PMV/PPD and adaptive models

IAQ Advanced Advanced indoor air quality analysis

Acoustics Advanced Detailed acoustical analysis with sound path modeling

Lighting Advanced Advanced lighting design with daylight integration

Controls Advanced Model predictive control and fault detection

22. VENTILATION & AIR SYSTEMS (Blue accent)

Exhaust Fan Sizing Size roof and wall exhaust fans

Air Change Calculator Calculate room air changes per hour

Makeup Air Unit Size makeup air units

Energy Recovery Wheel Size energy recovery wheels with effectiveness calculations

23. HELP & DOCUMENTATION (Purple accent)

Interactive Help Context-sensitive help with search, glossary, and FAQ

User Guides Open comprehensive step-by-step user guides

3.4 Top Menu Bar

The menu bar runs across the top of the window and contains five menus.

3.4.1 File Menu

New Project Ctrl+N Creates a new empty project. If you have
unsaved changes, prompts to save first.

New Project Wizard... Ctrl+Shift+N Opens the multi-step Project Setup Wizard
(see Section 4.2)

Open Project... Ctrl+O Opens a file dialog to select and load an
existing .mep or legacy .edsp project file

--- --- (separator)

Save Project Ctrl+S Saves the current project to its existing .mep
file. If no file path exists, behaves like Save
As.
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Save Project As...

Sync to Revit...

Share Project...

Open Shared Project...

Team Online...

Generate PDF Report...

Clear All Data

Exit

3.4.2 Settings Menu

Ctrl+Shift+S

Ctrl+R

(none)

(none)

(none)

Ctrl+P

Ctrl+Q

Opens a file dialog to save the project to a
new .mep file location

(separator)

Pushes project data back to Revit. Only
enabled when launched from the Revit add-in.

(separator)
Opens the cloud collaboration dialog to share
the current project with team members.

Requires cloud authentication.

Opens a dialog listing projects shared with
you by other team members.

Shows which team members are currently
online and their active projects.

(separator)

Opens the Report Engine to generate a
professional PDF report of the current project

(separator)

Resets all project data to defaults. Prompts
for confirmation.

(separator)

Closes the application. If you have unsaved
changes, prompts to save first.

Submenu listing all 40+ themes. Selecting a theme instantly changes
the application appearance. A checkmark indicates the currently active

Theme >

Code Standards >

- 1PC >
--CPC >

--UPC >

-- ASHRAE 90.1 >
-- Title 24 >

--1ECC >
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theme.

(separator)

Submenu with sub-menus for each code family. Select which version
of each code standard to use in calculations:

2024, 2021, 2018, 2015
2025, 2022, 2019, 2016

2024, 2021, 2018

2025, 2022, 2019, 2016,

2025, 2022, 2019, 2016
2024, 2021, 2018, 2015

(separator)

2013
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Company Information...

User Account >

-- Login...

-- Logout

-- Change Password...

-- Two-Factor Authentication...

-- License Management...

-- User Management...

3.4.3 Tools Menu

Opens a dialog to enter your company name, address, phone, email,
and logo for use in reports and compliance documents

(separator)

Submenu with account management options:

Opens the login dialog (if not currently logged in)

Logs out the current user

Opens a dialog to change your password (requires current password)
Opens the 2FA settings dialog to enable, disable, or manage 2FA

Opens the License Management dialog (see Section 2.3 for license
details)

Opens the user administration panel (admin role only)

Energy Model Wizard...

Cost Estimation...

3D Visualization >
-- View Building Model...

-- CFD - Airflow Analysis...

-- CFD - Temperature Distribution...

-- CFD - Thermal Comfort (PMV)...

Import Building Data >

-- Import IFC File (Revit/AutoCAD)...

-- Import gbXML File...

Envelope Editor...

3.4.4 View Menu

Opens a detailed building energy model setup
wizard

(separator)

Opens the HVAC cost estimation tool
(separator)

Submenu:

Launches the 3D building model viewer
CFD analysis for airflow patterns

CFD analysis for temperature mapping
CFD analysis for PMV/PPD thermal comfort
(separator)

Submenu:

Import an IFC file from BIM software
Import a gbXML file for energy modeling
(separator)

Opens the wall/roof/floor assembly editor

Dashboard
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- o= (separator)
Window Mode > Submenu:
-- Separate Windows Each tool opens in its own independent

window (default)

-- Tabbed (MDI) Tools open as tabs within the main window
using Multiple Document Interface

(separator)

Close All Tool Windows Ctrl+Shift+Q Closes all currently open tool windows
- - (separator)

Tile Windows Arranges all open tool windows in a tiled

layout (MDI mode only)

Cascade Windows Arranges all open tool windows in a
cascading layout (MDI mode only)

3.4.5 Help Menu

About Shows the application version, copyright, and system information

- (separator)

Contact Support... Opens a dialog with support contact information

Submit Feedback... Opens a feedback submission form

Report a Bug... Opens a bug report form (same as feedback but pre-configured for bug
reports)

- (separator)

Help Contents... Opens the searchable Help Browser with 48 help entries covering all

major tools (v1.2)

Check for App Updates... Manually checks GitHub Releases for a newer version (v1.2)
Check for Code Updates... Checks the server for any updated code standard data

- (separator)

Documentation > Submenu:

-- Generate User Guide PDF... Generates a comprehensive user guide in PDF format

-- Generate Packaging Guide PDF... Generates a guide for packaging and distribution

3.5 Status Bar

The status bar runs along the bottom of the window. It displays:

« Left side: Current status messages (e.g., "Ready", "Calculating...", "Project saved", module loading status)
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 Center: Current project file path (if a project is loaded)

* Right side: User name and role indicator (e.g., "john@acme.com [User]")

3.6 Window Modes

JAS Engineering Suite supports two window modes, selectable from View > Window Mode:
Separate Windows (Default):

 Each tool opens in its own independent OS window.

* You can arrange windows side-by-side, drag them to different monitors, minimize/maximize independently.
e The main launcher window stays open as the sidebar/menu hub.

« Best for multi-monitor setups.

Tabbed (MDI):

« Tools open as tabbed sub-windows within the main application window.
 The central area becomes an MDI workspace where you can tile or cascade sub-windows.
*» Use View > Tile Windows or View > Cascade Windows to arrange.

* Best for single-monitor setups where you want everything contained in one window.

4. Project Setup and Management

4.1 File > New Project (Ctrl+N)

Creating a new project resets all data to defaults:

1. Click File > New Project or press Ctrl+N.

2. If you have unsaved changes in the current project, a dialog appears:

* Title: "Unsaved Changes"

» Message: "You have unsaved changes. Do you want to save before creating a new project?"
* Buttons: Save | Discard | Cancel

* Click Save to save first (opens Save dialog if needed), then creates the new project.
* Click Discard to abandon changes and create a new project.

* Click Cancel to abort and return to your current work.

3. Once confirmed, all project data is cleared to defaults.

4. A confirmation dialog appears: "New project created."

5. The window title updates to: "JAS Engineering Suite - Untitled"

6. You are returned to the dashboard, ready to begin a new project.
4.2 File > New Project Wizard (Ctrl+Shift+N)
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The Project Setup Wizard guides you through creating a project with pre-configured settings in four steps.

Step 1: Project Info

Project Name A descriptive name for your project "Main Street Office Building"
Project Number Your firm's project tracking number "2026-0145"

Client Name The client or building owner "Acme Properties LLC"
Location City and state of the building "Sacramento, CA"

Engineer The engineer of record "John Smith, PE"

Step 2: Building

Building Type Primary use classification Office Building, Retail/Shopping,
Healthcare/Medical, Educational (K-12),
Educational (Higher Ed), Hotel/Hospitality,
Residential Multifamily, Industrial/Warehouse,
Restaurant/Food Service, Laboratory, Data
Center, Assembly/Theater, Religious, Parking
Garage, Mixed Use, Other

Gross Area (ft2) Total building gross floor area Numeric input (e.g., 50000)

Number of Floors Total number of above-grade floors Numeric input (e.g., 3)

Step 3: Climate & Codes

Climate Zone Type Choose "ASHRAE 90.1" or "California Title 24"

Climate Zone Select from a dropdown of all zones (see full list below)

Energy Code Selected code standard (ASHRAE 90.1-2022, Title 24-2022, etc.)
Plumbing Code Selected plumbing code (IPC 2024, CPC 2022, UPC 2024, etc.)

ASHRAE Climate Zones:
1A - Very Hot, Humid (Miami)
* 2A - Hot, Humid (Houston)
* 2B - Hot, Dry (Phoenix)
* 3A - Warm, Humid (Atlanta)
* 3B - Warm, Dry (Los Angeles)
* 3C - Warm, Marine (San Francisco)
e 4A - Mixed, Humid (New York)
* 4B - Mixed, Dry (Albuquerque)
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* 4C - Mixed, Marine (Seattle)

* 5A - Cool, Humid (Chicago)

* 5B - Cool, Dry (Denver)

* 5C - Cool, Marine (Vancouver)
* 6A - Cold, Humid (Minneapolis)
* 6B - Cold, Dry (Helena)

» 7 - Very Cold (Duluth)

* 8 - Subarctic (Fairbanks)

California Title 24 Climate Zones:

e CZ1 - Arcata through CZ16 - Mt. Shasta (16 zones)

Step 4: Systems

Select one or more HVAC system types for your project:

VAV with Reheat Variable air volume with hot water reheat coils
Packaged Rooftop Direct expansion packaged units
Chilled Water AHU Central plant with air handling units
VRF/VRV Variable refrigerant flow multi-split
WSHP Water source heat pumps

GSHP Ground source heat pumps
Radiant Radiant heating/cooling with DOAS
Fan Coil Units 4-pipe fan coil with central plant
PTAC/PTHP Packaged terminal units

Split Systems Ductless mini-split systems
Navigation:

» Back button: Returns to the previous step

» Next button: Advances to the next step (validates current step data first)

» Cancel button: Aborts the wizard and returns to the previous project state
» On the final step, the Next button changes to Finish

The step indicator at the top shows your current progress with four labeled steps: "1. Project Info", "2. Building", "3. Climate
& Codes", "4. Systems". The current step is highlighted.

4.3 File > Open Project (Ctrl+0O)

1. Click File > Open Project or press Ctrl+O.

2. If you have unsaved changes, the "Unsaved Changes" dialog appears (same as described in Section 4.1).
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3. A standard Windows file dialog opens.
4. Default directory: YUJSERPROFI LE% Docunent s\ JAS Proj ect s\

5. File filter: "JAS Engineering Project (.mep)" is selected by default. You can also choose "Legacy Project (.edsp)" or
"All Files (¥)".

6. Navigate to and select your project file.

7. Click Open.

8. The project data loads. A confirmation dialog appears showing:

* "Project loaded from: [filepath]"

9. The window title updates to: "JAS Engineering Suite - [Project Name]"

10. All project data (zones, loads, equipment, weather, calculations) is restored.

Legacy .edsp files: If you open a legacy . edsp file (from an older version), the application imports it and displays a
message: "Legacy .edsp file imported successfully. Please use 'Save As' to save in the new unified .mep format." The
project is marked as having unsaved changes to encourage saving in the modern format.

4.4 File > Save / Save As
Save (Ctrl+S):

« If the project has been previously saved to a . nep file, it is saved to the same location.
« If this is a new project that has never been saved, the Save As dialog opens instead.

Save As (Ctrl+Shift+S):

. A standard Windows file dialog opens.

. Default filename: The project name with underscores replacing spaces, plus . mep extension.
. Default directory: %JSERPROFI LE% Document s\ JAS Pr oj ect s\

. File filter: "JAS Engineering Project (*.mep)"

. Choose a location and filename and click Save.

. If you omit the . mep extension, it is automatically appended.

. A confirmation dialog appears: "Project saved to: [filepath]"

o N o o b~ W N P

. The window title updates with the new file name.

4.5 Project File Format (.mep)

JAS Engineering Suite project files use the . nep extension. The file is a JSON document containing:

* Project metadata: name, number, client, engineer, creation date

* Building information: type, area, floors, location, climate zone, latitude/longitude, elevation

» Zone definitions: rooms with dimensions, constructions, occupancy, lighting, equipment loads
 Calculation results: heating/cooling loads, airflow, equipment selections

» Tool settings: saved inputs for duct sizer, pipe sizer, pump calculator, etc.

» Energy simulation results: 8760-hour data, site EUI, annual cost
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* Equipment selections: manufacturer data, model numbers, capacities
» Control sequences: written sequences of operation

e Company information: for report headers

e Compliance check results: pass/fail status for applicable codes

The . nep file is human-readable JSON text and can be opened in any text editor for inspection, though direct editing is not
recommended.

4.6 Recent Projects

The application maintains a list of your 10 most recently opened project files. These appear in:
1. The Dashboard's "Recent Projects" list (left column)
2. Recent project buttons in the Standalone Dashboard's Recent Projects card

Double-clicking a recent project entry in the dashboard opens it immediately.

4.7 Auto-Save Behavior

JAS Engineering Suite does not currently implement automatic periodic saving. You must manually save your project using
Ctrl+S or File > Save.

However, the application protects against data loss by:

* Prompting to save unsaved changes when you create a new project, open another project, or exit the application

* Tracking an unsaved_changes flag that is set whenever you modify any project data

5. Setting Location and Weather Data

5.1 How to Select City/State

Weather data selection is done through the Energy Calculations module:

1. Open Energy Calculations from the sidebar or Quick Actions.

2. In the project/building setup area, find the Location section.

3. Use the State dropdown to select a US state (all 50 states plus territories).

4. Use the City dropdown to select from available cities in that state.

5. The application includes ASHRAE design weather data for 523+ US locations.

Alternatively, in the Project Setup Wizard (Step 3), you select a climate zone which determines the representative
weather location.

5.2 ASHRAE Design Conditions

When you select a location, the following ASHRAE design conditions are automatically populated:
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Cooling Design Temperatures:

Percentile

0.4% Cooling DB/MCWB

1% Cooling DB/MCWB

2% Cooling DB/MCWB

Dry-bulb temperature exceeded only 0.4% of annual hours (about 35
hours). Used for most commercial HVAC design. This is the most
conservative (highest temperature) design condition.

Dry-bulb temperature exceeded only 1% of annual hours (about 88
hours). Used for some residential and light commercial design.

Dry-bulb temperature exceeded only 2% of annual hours (about 175
hours). Used for economy/budget designs with some risk of not
meeting load on extreme days.

MCWB = Mean Coincident Wet Bulb temperature (the average wet-bulb temperature that occurs when the dry-bulb is at

the design value).

Heating Design Temperature:

99.6% Heating DB

99% Heating DB

Additional Data Available:

« Daily range (difference between daily high and low tem
» Wind speed and direction (for infiltration calculations)

« Solar radiation data (for 8760-hour simulations)

» Atmospheric pressure (affects air density calculations)

* Humidity ratio at design conditions

5.3 Climate Zone Auto-Detection

Dry-bulb temperature that is exceeded 99.6% of annual hours (i.e., it is
colder than this only 0.4% of the time, about 35 hours per year). This is
the standard heating design temperature for commercial buildings.

Temperature exceeded 99% of hours (colder only 1% of the time).
Less conservative.

peratures)

When you select a city/state location, the application automatically determines:

1. ASHRAE climate zone (1A through 8) based on ASHRAE Standard 169

2. California Title 24 climate zone (CZ1 through CZ16) if the location is in California

3. Elevation above sea level for the selected location

The climate zone drives:

« Default insulation requirements for envelope compliance

« Default HVAC system efficiency requirements
« Default fenestration U-factor and SHGC limits

* Building envelope prescriptive requirements
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5.4 Manual Override of Design Conditions

You can manually override any auto-populated design condition:

1. In the Energy Calculations module, locate the weather data section.
2. Individual fields for cooling design DB, WB, heating design DB, and other parameters can be edited directly.
3. A "Reset to Default" or similar option restores the ASHRAE values for the selected location.

This is useful for:
» Custom microclimate corrections (urban heat island, coastal effects)
» Altitude corrections for mountain sites not in the database
« Client-specified design conditions that differ from ASHRAE

« Future-proofing designs for anticipated climate changes

5.5 Altitude and Its Effect on Calculations

Altitude (elevation above sea level) affects HVAC calculations in several critical ways:

Affected Calculation How Altitude Changes It

Sensible Heat Factor The standard factor 1.08 (= 60 min/hr x 0.075 Ib/ft3 x 0.24 BTU/Ib-F) is
for sea level. At altitude, air density decreases. The factor must be
multiplied by the pressure ratio (local pressure / 14.696 psi).

Latent Heat Factor The standard factor 4840 (= 60 min/hr x 0.075 Ib/ft3 x 1076 BTU/Ib) is
also sea-level only and must be corrected for altitude.

Fan Performance Fans deliver the same volumetric flow (CFM) at altitude but move less
mass of air. Motor power requirements may change.

Boiling Point Water boils at lower temperatures at altitude, affecting steam and hot
water systems.

Combustion Air Gas-fired equipment must be derated at altitude (typically 4% per
1,000 ft above sea level).

The application automatically applies altitude corrections when a location's elevation is known. You can see and modify
the elevation in the building setup section of the Energy Calculations module.

6. Common Workflows

6.1 Load Calculation Workflow

A complete load calculation workflow follows these steps:

1. Create or open a project
¢ Click File > New Project Wizard (Ctrl+Shift+N)

» Complete all four wizard steps with your building information.
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2. Select weather location

* Open Energy Calculations from the sidebar.

« Select your State and City from the dropdowns.

« Verify the design conditions are appropriate.

3. Define building envelope

» Open Envelope Editor from the sidebar or Tools > Envelope Editor (Ctrl+Shift+E).
« Define wall assemblies with layers and U-factors.

* Define roof assemblies.

* Define floor assemblies.

« Define window/glazing types with U-factor and SHGC.

4. Add zones/rooms

* In the Energy Calculations module, add zones to your building.

* For each zone, define:

* Room name and number

* Area (ft2) and ceiling height (ft)

* Orientation (N, S, E, W)

» Wall/roof/floor construction assignments

» Window areas per orientation

» Occupancy (number of people, activity level)

« Lighting load (W/ft2)

» Equipment/plug load (W/ft2)

* Ventilation requirements (CFM/person and CFM/ft2)

5. Run calculations

* Click "Calculate" or the equivalent button in the Energy Calculations module.
» The engine computes peak heating and cooling loads for each zone using ASHRAE methodology.

* Results include: sensible cooling (BTU/hr), latent cooling (BTU/hr), total cooling (BTU/hr), heating load (BTU/hr),
supply CFM, outdoor air CFM.

6. Review results

» Examine zone-by-zone load summaries.

» Check building-level totals (total cooling tons, total heating MBH).

 Use the Building Analysis tool for performance metrics.

 Use the Data Visualizer (8760) for annual hourly profiles.

7. Generate reports

* Open Reports & Diagrams from the sidebar.

* Select report type (Load Summary, Zone Detail, System Summary, etc.).

* Click "Generate" to create a PDF report.
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* Or use File > Generate PDF Report (Ctrl+P) for the full project report.

6.2 Equipment Sizing Workflow
1. Complete load calculations (Section 6.1 above).
2. Open Equipment Schedule or Equipment Wizard from the sidebar.
3. The wizard reads your calculated loads and recommends equipment:
* AHU sizing based on total CFM and cooling/heating coil loads
« Chiller sizing based on total building cooling load
« Boiler sizing based on total building heating load
» Pump sizing based on flow rates and head requirements
4. Select specific manufacturer equipment from the catalog database (Trane, Carrier, Greenheck, etc.).
5. Verify equipment meets load requirements with appropriate safety factors.

6. Generate equipment schedules for inclusion in construction documents.

6.3 Duct/Pipe Sizing Workflow
Duct Sizing:
1. Open Duct Sizer from the sidebar.
2. Enter the required airflow (CFM) for the duct section.
3. Select the duct type: Round, Rectangular, or Flat Oval.
4. Choose the sizing method:
» Equal Friction: Specify a friction rate (e.g., 0.08 in.wg/100ft)
* Velocity: Specify a maximum velocity (e.g., 1200 FPM for main ducts)
5. The tool calculates the required duct dimensions, actual velocity, friction rate, and equivalent diameter.
6. For rectangular ducts, multiple aspect ratio options are shown.
Pipe Sizing:
1. Open Pipe Sizer from the sidebar.
2. Enter the required flow rate (GPM for hydronic, or fixture units for plumbing).
3. Select the pipe material (copper, steel, PVC, CPVC, etc.).
4. Choose the sizing criteria:
» Maximum velocity (e.g., 4 ft/s for copper)
» Maximum friction loss (e.g., 4 ft/100ft)

5. The tool calculates the required pipe diameter, actual velocity, friction loss, and Reynolds number.

6.4 Report Generation Workflow

1. Ensure your project has completed calculations (loads, equipment, etc.).
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2. Open the Report Engine from the Enterprise Tools category, or use File > Generate PDF Report (Ctrl+P).
3. Select the report sections to include:

* Project Information and Cover Sheet

¢ Building Summary

* Load Calculation Summary

» Zone-by-Zone Detall

* Equipment Schedules

» Compliance Summary

» Energy Simulation Results

* Cost Estimate

 Narrative Report

4. Configure report options (company logo, header/footer text, page numbering).
5. Click "Generate Report".

6. A PDF file is created. Choose the save location.

7. The PDF is opened in your default PDF viewer.

6.5 Cloud Collaboration Workflow

Cloud collaboration allows team members to share and synchronize project files through the Railway-hosted REST API.
Sharing a project:
1. Save your project locally (Ctrl+S).
2. Click File > Share Project...
3. The Share dialog appears. Enter the email addresses of team members you want to share with.
4. Set access level: "Edit" (full read/write) or "View" (read-only).
5. Click "Share". The project is uploaded to the cloud server.
6. Team members receive access and can open the shared project.
Opening a shared project:
1. Click File > Open Shared Project...
2. A list of projects shared with you appears.
3. Select a project and click "Open".
4. The project is downloaded and opened locally.

Synchronization:

* When you save a project that has been shared, changes are automatically synced to the cloud.

» The collaboration system uses a REST-only architecture (no WebSocket/SocketlO). Syncing occurs on save, not in
real-time.

JAS Engineering Suite v1.2 — Sample Project User Guide Page 37



JAS Engineering Suite Guide 00 Getting Started

* Project locking prevents simultaneous edits. When you open a shared project, it is locked to your session. Other
users see it as "locked" until you close or save.

Requirements:

* You must be logged in with a cloud-authenticated account (JWT token).
* Internet connection required.

» The Share Project, Open Shared Project, and Team Online menu items are enabled only after successful cloud
authentication.

7. Keyboard Shortcuts and Tips

7.1 Complete Keyboard Shortcuts Reference

File Operations:

Ctrl+N New Project

Ctrl+Shift+N New Project Wizard

Ctrl+O Open Project

Ctrl+S Save Project

Ctrl+Shift+S Save Project As

Ctrl+P Generate PDF Report

Ctrl+R Sync to Revit (when connected)
Ctrl+Q Exit Application

View Operations:

Ctrl+D Show Dashboard

Ctrl+Shift+Q Close All Tool Windows

Tool Shortcuts:

Ctrl+Shift+w Energy Model Wizard
Ctrl+E Cost Estimation
Ctrl+Shift+E Envelope Editor
Help:
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F1 Context-sensitive help for the active tool window (v1.2)

Within Dialogs:

Enter Confirm/Submit (Login, Register, Verify 2FA, etc.)
Escape Cancel/Close dialog

Tab Move to next field

Shift+Tab Move to previous field

7.2 Right-Click Context Menus

« Sidebar Tool Buttons: Right-click to see "Add to Favorites" or "Remove from Favorites" options.
» Recent Projects List: Right-click for "Open", "Open in File Explorer", or "Remove from Recent" options.
» Table Cells (in calculation tools): Right-click for "Copy", "Copy Row", "Export Table" options.

 Text Fields: Standard Windows context menu (Cut, Copy, Paste, Select All).

7.3 Theme Switching

You can change the application theme at any time. The theme affects all visual elements including the sidebar, menus,
dialogs, and tool windows.

Method 1: Settings Menu

1. Click Settings > Theme.
2. Browse the list of 40+ themes organized by category.
3. Click any theme to apply it instantly.

Method 2: Login Dialog

1. The theme dropdown in the upper-right corner of the login dialog lets you preview themes before even logging in.

Available Theme Categories:

Dark Themes 8 Dark Professional, Dark Emerald, Dark
Purple, Dark Classic, Midnight Blue, Dark
Crimson, Charcoal, Nord Dark

Light Themes 8 Clean Professional, Warm Professional,
Modern Minimal, Classic Engineering, Ocean
Blue, Soft Rose, Forest Green, Slate Gray

Lightsaber Themes 8 Saber: Cyan (JAS) [default], Blade: Blue,

Blade: Green, Blade: Crimson, Blade: Violet,
Blade: Amber, Blade: Frost, Blade: Flame
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Lightning Themes 5
Special Edition 10
Color Themes 12

The default theme is Saber: Cyan (JAS), a dark theme with electric cyan accents.

Lightning: Thunder, Lightning: Storm,
Lightning: Tempest, Lightning: Plasma,
Lightning: lon

Special: Crystal, Special: Steel Alloy, Special:
Graphite, Special: Hologram, Special:
Ethereal, Special: Shadow, Special: Radiant,
Special: Titanium, Special: Empire, Special:
Alliance, Special: Cityscape

Color: Royal Blue, Color: Frost White, Color:
Flame Orange, Color: Crimson, Color: Dark
Red, Color: Lime Green, Color: Orchid Purple,
Color: Lemon Yellow, Color: Maroon, Color:
Amber Gold, Color: Crimson Red, Color: Dark
Steel

Custom Themes: You can create custom themes through the Theme Manager. Custom themes appear in the theme list

with a "Custom:" prefix.

7.4 Export Options

Most calculation tools support exporting results in multiple formats:

PDF -pdf
Excel Xlsx
Text Ixt
Csv .csv

Professional reports for clients and submittal
packages

Data analysis, further calculations, and
custom formatting

Simple plain-text export for records or quick
reference

Data import into other software or databases

Export buttons are typically found in the toolbar or bottom-right area of each tool's interface.

7.5 Logo Customization

JAS Engineering Suite features 39 logo variations that you can select to personalize the splash screen and login

background:

Standard Logos: Blue, Anakin, AT, Bronze, BZ, Cal, Dark Side, Electric Blue, Gold, Industrial, Kylo, Luke, Magenta,

Orange, Pink, Purple, Senate Blue, Silver Blue, Sith, White, Windu

Force Lightning Logos: Blue FL, Blue Saber FL, Bronze FL, Dark Magenta FL, Dark Saber FL, Dark Side FL, Green FL,
Green Saber FL, Kylo FL, Orange FL, Pink FL, Purple FL, Purple Saber FL, Red FL, Teal FL, Teal Saber FL, Yellow FL,

Yellow Saber FL

To change the logo:
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1. Go to the application settings (stored in the Windows registry under
HKCU\ Sof t war e\ JSEngi neer i ng\ JSEngi neeri ngSui t e).

2. Change the appear ance/ | ogo_st yl e value to one of the logo names listed above.

3. Restart the application to see the new logo on the splash screen and login dialog.

8. Troubleshooting

8.1 Common Errors and Fixes

"Module not found" or "Failed to load module" at Startup

Symptom: Warning messages appear in the console during startup, such as [ WARNING Mbdul e ' xxx' not avail abl e:
No nodul e naned ' xxx'.

Cause: Some optional modules may not be available in your build.
Fix:
» These warnings are typically non-critical. Core functionality works regardless.

« If a specific tool fails to launch, it is likely because its optional dependency is missing from the build.

 Contact support if a critical module is unavailable.

Application Window Appears Very Small or Ul Elements Overlap

Symptom: The window opens but buttons, text, and layouts appear cramped or overlapping.
Cause: Display scaling is set above 125% in Windows Settings.
Fix:

. Right-click the Desi gn_Sui t e. exe file.

. Select Properties > Compatibility tab.
. Click "Change high DPI settings".

1
2
3
4. Check "Override high DPI scaling behavior".
5. Set "Scaling performed by:" to "Application".
6

. Click OK and relaunch.

Login Fails with "Invalid email or password"

Symptom: You are certain your credentials are correct but login fails.
Possible Causes and Fixes:

1. Case sensitivity: Email addresses are converted to lowercase automatically. Ensure you are typing the correct
email.

2. Database corruption: If the local database is corrupted:
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» Navigate to % OCALAPPDATA% MEP- Desi gn- Sui t e\
* Rename or delete users. db (this will require you to register again)
 Relaunch the application and create a new account

3. Multiple installations: If you have the application installed in multiple locations, each has its own database.
Ensure you are using the same EXE location where you registered.

2FA Code Rejected

Symptom: The authenticator app shows a code, but the application says "Invalid verification code."”
Fixes:

1. Clock sync: TOTP codes are time-based. If your phone's clock is out of sync, codes will be rejected. On your
phone:

* Android: Settings > System > Date & Time > enable "Set time automatically”
¢ iOS: Settings > General > Date & Time > enable "Set Automatically”

2. Code expiry: TOTP codes change every 30 seconds. If you enter a code just as it is about to expire, it may fail.
Wait for a fresh code.

3. Wrong account: Ensure you are reading the code from the correct authenticator entry (labeled "JAS Engineering
Suite").

4. Use a backup code: If TOTP codes continue to fail, use one of your saved backup codes.

Application Crashes or Freezes

Symptom: The application becomes unresponsive or closes unexpectedly.
Fixes:

1. Check available RAM: Close other applications. 8760-hour simulations on large buildings can consume 2-4 GB of
RAM.

2. Check for crash dialog: The application has a global exception handler. If a crash is recoverable, a dialog will
appear with the error message. Read the error and save your work.

3. Update graphics drivers: If the 3D visualization or splash screen causes issues, update your GPU drivers.
4. Run from console: For diagnostic purposes, open Command Prompt, navigate to the EXE directory, and run:
Desi gn_Sui t e. exe

Any error messages will appear in the console window.

Project File Won't Open
Symptom: Opening a .mep file shows an error.

Fixes:

1. Corrupted file: Open the .mep file in a text editor (Notepad, VS Code). If the JSON is malformed (truncated,
missing brackets), the file may have been corrupted by an incomplete save. Try restoring from a backup.

2. Legacy format: If the file is a .edsp (old format), the application should import it automatically. If it fails, try
renaming the extension to .mep and attempting to open.
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3. Version mismatch: If the project was created with a newer version of the application, some data fields may not be
recognized by an older version. Update to the latest version.

8.2 Performance Tips for Large Projects

1. Close unused tool windows: Each open tool window consumes memory. Use View > Close All Tool Windows
(Ctrl+Shift+Q) when you are done with tools.

2. Use Separate Windows mode instead of Tabbed MDI mode for better memory management.

3. Limit 8760-hour simulation zones: Running hourly simulations on buildings with 100+ zones can take several
minutes and consume significant memory. Consider running zone groups separately.

4. Disable Al features when not needed: The Al Design Assistant and Proactive Al Engineer consume resources.
Close them when not actively in use.

5. Save frequently: Use Ctrl+S to save regularly. If the application crashes, you will only lose work since your last
save.

8.3 Settings Reset

If the application behaves unexpectedly due to corrupted settings:

1. Close the application completely.

2. Navigate to % OCALAPPDATA% MEP- Desi gn- Sui t e\

3. Delete or rename the set tings. j son file.

4. Relaunch the application. Default settings will be recreated.

Your user account and projects are NOT affected by deleting settings.json. Only your theme choice, window mode
preference, recent projects list, and sidebar collapse states are reset.

8.4 Getting Help

Within the application:

* Help > About: Shows version information and system details.

* Help > Contact Support: Opens a dialog with support contact information.

* Help > Submit Feedback / Report a Bug: Sends feedback or bug reports.

* Interactive Help (sidebar): Browse a searchable help system with glossary and FAQ.

External support:

* Email: james@jsengineeringsolutions.com

* Website: https://jsengineeringsolutions.com

8.5 Uninstalling

Since JAS Engineering Suite is a portable application:

1. Close the application.
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2. Delete the Desi gn_Sui t e. exe file.

3. Optionally, delete the settings and user database folder:

%_OCALAPPDATA% MEP- Desi gn- Sui t e\
4. Optionally, delete the Windows registry entries:

HKCW Sof t war e\ JSEngi neeri ng\ JSEngi neeri ngSui te
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Appendix A: License Management

The License Management dialog (accessible from Settings > User Account > License Management) shows:
Current License Status section:

» Status: ACTIVE (green), ACTIVE (Offline) (orange), or EXPIRED/INVALID (red)

e Type: Standard, Trial, Admin, etc.

* Key: The license key with middle segments masked for security (e.g., MEP-XXXX-XXXX-ABCD)

* Expires: The expiration date and number of days remaining, or "Never (Perpetual)" for permanent licenses
e Licensed To: Your name and email

» Machine ID: A unique identifier for your computer (used for single-machine license enforcement)

Activate New License section:

* A text input field to enter a new license key

« An "Activate" button to attempt activation

* Info text: "Enter a license key from the JAS Engineering web portal.”

* Activation is attempted first against the online portal, then falls back to local validation

Refresh License Status: A button to re-check the license status against the server.
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Appendix B: Revit and AutoCAD Integration

Launching from Revit

When JAS Engineering Suite is launched via the Revit add-in:

1. In Revit, click the JAS Engineering Suite button in the Add-Ins ribbon tab.
2. The application launches with the - -revi t - pr oj ect argument.

3. Building data is automatically imported from the active Revit model:

« Project name, number, client

* Building location (city, state, latitude, longitude, elevation)

* All spaces/rooms with areas, volumes, and space types

» Wall assemblies with U-factors (from Revit analytical properties)

» Windows with U-factor, SHGC, and VT values

» Roofs with thermal properties and cool roof data

* Plumbing fixtures with IPC fixture unit counts

* Piping with system types, diameters, and lengths

* HVAC equipment with capacities and served spaces

4. The Sync to Revit menu item (File > Sync to Revit, Ctrl+R) becomes enabled.

5. After performing calculations in JAS Engineering Suite, click Sync to Revit to push results back to the Revit model.

AutoCAD Plugin

The AutoCAD plugin provides similar bidirectional communication for importing space data and exporting calculation
results.
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Appendix C: Al Features

Al Setup Wizard

On first launch, JAS Engineering Suite displays an Al Setup Wizard to help you configure cloud Al. Three providers are
supported:

Google Gemini (Recommended) Free tier available General design assistance, code compliance
questions

Anthropic Claude Paid API Detailed engineering narratives, report
generation

OpenAl Paid API Equipment selection reasoning, sequence
writing

To set up: go to Settings > Al Assistant > Al Setup Wizard, paste your API key, and click Test Connection. You can
change providers anytime via Settings > Al Assistant > Al Settings.

Al Design Assistant

The Al Design Assistant (found in the Al & AUTOMATION sidebar category) provides a chat interface for engineering
guestions:

» Code requirements: "What is the minimum ventilation rate for an office per ASHRAE 62.1?"
« Design guidance: "What chiller type is best for a 200-ton healthcare facility?"

» Debug calculations: "Why is my cooling load so high for Zone 3?"

» Report narratives: "Write an executive summary for my energy model"

The Al Assist button (robot icon) also appears in the status bar of every tool window. Click it for context-aware Al help
specific to the tool you're using — it automatically includes your current project data and calculation results.

Proactive Al Engineer

The Proactive Al Engineer automatically monitors your design and provides real-time feedback:

 Load Validation: After calculating loads, Al checks SF/ton, CFM/SF, and ventilation rates against ASHRAE
benchmarks

* Equipment Scheduling: Auto-generates equipment schedules when loads are finalized

* Sequence Writing: Creates sequences of operation for common HVAC systems (per ASHRAE GL36)
e Compliance Checking: Cross-references design parameters against applicable codes

» Toast Notifications: Al insights appear as non-intrusive toast popups

Toggle proactive mode on/off via Settings > Al Assistant > Proactive Mode.
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Appendix D: New in v1.2 (February 2026)

Parametric Sweep & System Comparison

Side-by-side comparison of up to 5 HVAC system types (VAV, RTU, VRF, WSHP, DOAS+Radiant) with automated energy
cost, first cost, maintenance cost, and CO2 emissions analysis. Found in the Analysis & Optimization sidebar category.

Medical Gas Piping Design

NFPA 99 compliant medical gas system design including oxygen, medical air, vacuum, nitrogen, and nitrous oxide.
Automatic pipe sizing, source equipment sizing, and zone valve box layout. Found in the Plumbing & Piping sidebar
category.

Plumbing Utilities

Compressed air system sizing, emergency eyewash/shower compliance (ANSI Z358.1), thermal expansion tank sizing,
and domestic water flush-out calculations. Found in the Plumbing & Piping sidebar category.

Refrigerant Compliance

ASHRAE Standard 15 refrigerant safety analysis with AIM Act GWP phase-down tracking, room volume calculations,
detector placement, and ventilation requirements. Found in the HVYAC Systems sidebar category.

Revit Live Sync

Real-time bidirectional synchronization with Autodesk Revit via WebSocket connection. Rooms and zones auto-populate
when the Revit model updates, and calculation results push back to Revit parameters automatically.

Theme System

40+ built-in themes with custom theme editor. All tool windows inherit the active theme — no more hardcoded dark
stylesheets.

7-Step Workflow Navigation

Visual workflow bar at the top of the main window guides you through: Project Setup — Load Calculations - System
Selection - Equipment Sizing — Energy Simulation — Code Compliance - Reports. Green checkmarks show completed
steps.
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Appendix E: New in v1.2 (February 2026)

CLI/Batch Runner

A new command-line interface (cl i _runner. py) allows you to run load calculations, energy simulations, and compliance
checks without launching the GUI. Five subcommands are available:

| oad-cal ¢ Run room-by-room heating/cooling load calculations
energy-sim Run 8760-hour annual energy simulation

conpl i ance Check compliance against ASHRAE 90.1, Title 24, or UFC
info Print project summary to terminal

bat ch Run parametric sweeps from a JSON configuration file

All commands support JSON, CSV, and summary output formats. Example usage:

python cli _runner.py |oad-calc project.nep --output results.json
python cli _runner.py conpliance project.nep --standard title24 -f csv -o check. csv
pyt hon cli _runner.py batch wal |l _study.json

The batch command is particularly powerful for parametric studies -- sweep wall R-value, window SHGC, setpoints, or
supply air temperature across multiple values and compare the results in a spreadsheet.

See Guide 10: New Features in v1.2 for detailed documentation of each subcommand and batch configuration format.

Auto-Update System

JAS Engineering Suite now checks for new versions automatically once per day on startup. When a newer version is
found, an update natification dialog appears with three options:

e Download Update -- Opens the download URL in your web browser
* Remind Me Later -- Dismisses the dialog; check runs again next launch
» Skip This Version -- Permanently ignores this specific version

To check manually at any time: Help > Check for App Updates...

The update check runs silently in a background thread and never blocks the Ul. If you are offline, no error is shown.

Offline Help System

Press F1 in any tool window for instant context-sensitive help. The help system includes:

* 48 help entries covering all major tools (load calculations, HVAC sizing, equipment selection, plumbing, fire
protection, energy analysis, compliance, controls, reports, and specialty tools)

» Searchable Help Browser (Help > Help Contents) with category tree, full-text search, and bookmarks

*« Embedded content -- no internet connection or external files required
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* Engineering formulas with variable definitions
* Input field descriptions with units and valid ranges
« ASHRAE/SMACNA/NFPA references for each tool

* Practical tips and common engineering pitfalls

Web Dashboard

A new web-based dashboard at https://jsengineeringsol utions.com provides project management and team
collaboration from any web browser:

* Project list with create, upload (.mep), view, share, and delete actions

* Project detail view with Rooms, Systems, Results, and Compliance tabs
e Team sharing with Viewer/Editor/Admin permission levels

« Activity feed showing recent project changes

» Account settings for password, 2FA, API keys, and license management

Login with the same credentials you use in the desktop application. Two-factor authentication uses the same TOTP secret
for both web and desktop.

This guide covers JAS Engineering Suite v1.2. For the latest information, visit https://jsengineeringsolutions.com or contact
support.

Copyright 2026 JS Engineering Solutions. All rights reserved.
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